Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4487

Summary: pump loses ability to do anything
Product: [Retired] Red Hat Linux Reporter: cjr
Component: pumpAssignee: Erik Troan <ewt>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: high    
Version: 6.0CC: cjr
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-23 20:42:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description cjr 1999-08-12 01:21:44 UTC

I have been able to get pump to a state in which it is
never able to perform its magic.  pump will timeout after
sometime with "Operation failed." but continue to run.
Subsequent pump -s or pump -r results in an "Operation
failed."  pump continues to operate (in a failed mode).
Of course, kill -KILL works great.

The only solution that I have found to this is rebooting
the computer (unacceptable).  Killing pump, tearing down
the entire network, etc. and restarting pump has no effect.

I have an strace and ltrace of pump if it would be useful
to anyone.


Comment 1 Bill Nottingham 1999-08-12 15:02:59 UTC
Does it still happen with the errata release (0.7.0)?

Comment 2 cjr 1999-08-18 02:00:59 UTC
Hi. in disguise.  Yes, this still happens under the
errata release of 0.7.0.

The specific instances of my problem are as follows.  I have two
computers that are connected to my Time Warner Motorolo cable modem.
It seems that this arrangement allows only one computer to use the
cable modem at a time.  I suspect that the cable modem associates the
MAC address with the computer that is allowed to talk.

To continues, whenever I want to use the Windows box, I run winipcfg
and renew the token.  This reassociates the cable modem with the
Windows box.  At this point, pump because hosed.

(Yes, masquerade.  I know.  I haven't had the time to get a second NIC
yet though since my last one... well... I digress.)

I go through all of the *conceivable* motions to get my system back
into a state where pump will work.  I...

. ifdown eth0 (fails)
. kill pump because pump -r hangs
. network stop
. kill pump in case pump -r was started by ifdown eth0
. rm /var/run/pump.sock
. network start

During network start, pump hangs and fails with Operation failed.
These steps were my latest iteration in attempt to get the machine
working again without having to reboot the machine.  Oh, these steps
are even conducted with the Windows box off the network.

I am fairly certain that it is not a release/renew problem with the
cable modem as it worked before the upgrade to RH 6.0.  Plus, the
Windows box is able to renew regardless if the Linux box has current

Once I reboot, it comes up lickity split.


Comment 3 Erik Troan 2000-02-23 20:42:59 UTC
This should be fixed for piglet.