Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4482

Summary: /dev/printer is a socket, not a device
Product: [Retired] Red Hat Linux Reporter: Matthew Galgoci <mgalgoci>
Component: devAssignee: David Lawrence <dkl>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: mgalgoci
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-08-12 15:01:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Matthew Galgoci 1999-08-11 22:15:04 UTC
Included in the dev rpm is /dev/printer, which shouldn't.
This is a unix socket that is normally created each time
that lpd is started so that the userland lp utils can
communicate with the lpd daemon.

The presence of the socket in the package seems to be
confusing a lot of folks who assume that the disappearance
of /dev/printer is a direct cause of print failure when
it is in fact a side effect.

Please remove /dev/printer from the dev rpm package. :)

Comment 1 Bill Nottingham 1999-08-12 15:01:59 UTC
fixed in dev-2.7.8.1-1.