Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4476

Summary: No hostnames possible in /etc/yp.conf
Product: [Retired] Red Hat Linux Reporter: Jos Vos <jos>
Component: ypbindAssignee: David Lawrence <dkl>
Status: CLOSED WORKSFORME QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-08-28 05:42:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jos Vos 1999-08-11 17:51:01 UTC
An entry like "ypserver myhost.my.domain" in /etc/yp.conf,
where the used hostname is listed in /etc/hosts (and
actually is the name of local host, because I tested it on a
slave server) does not work, while replacing the hostname
with its IP address works fine.

The comment lines in /etc/yp.conf suggest something else and
on a very old system (RHL 3.0.3) this also worked fine.

Comment 1 Jeff Johnson 1999-08-11 19:09:59 UTC
Check /etc/nsswitch.conf and make sure you have something like
     hosts:      files dns nisplus nis

Comment 2 Jos Vos 1999-08-11 19:28:59 UTC
Checked, /etc/nsswitch.conf is unchanged, so it says:
	hosts:      files nisplus nis dns

Comment 3 Preston Brown 1999-08-28 05:42:59 UTC
hmm, can't seem to duplicate this here.  Sounds like a DNS issue
though, not a ypbind issue -- I am using hostnames not IP addresses in
/etc/yp.conf just fine.