Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4471

Summary: Netscape crash after font fix -- caused by Cyrillic fonts
Product: [Retired] Red Hat Linux Reporter: csigler
Component: netscapeAssignee: David Lawrence <dkl>
Status: CLOSED WORKSFORME QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-08-17 16:53:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description csigler 1999-08-11 14:35:29 UTC
Hi,

A user reported to me that Netscape crashed on Java pages
*after* we did the font fix.  This happened when he clicked
on a Java button, not when Java loaded in Netscape.  This
happened on stock RH 6.0 installs with fontpath:

$ /usr/sbin/chkfontpath --list
Current directories in font path:
1: /usr/X11R6/lib/X11/fonts/misc:unscaled
2: /usr/X11R6/lib/X11/fonts/75dpi:unscaled
3: /usr/X11R6/lib/X11/fonts/100dpi:unscaled
4: /usr/X11R6/lib/X11/fonts/misc
5: /usr/X11R6/lib/X11/fonts/Type1
6: /usr/X11R6/lib/X11/fonts/Speedo
7: /usr/X11R6/lib/X11/fonts/75dpi

and with either netscape 4.51 or 4.61.

The fix is to remove the Cyrillic fonts:

# rpm -e XFree86-cyrillic-fonts-3.3.3.1-49

This stopped the crashing for us.  I'm not sure what
Russian users can do to fix this.  HTH.

				Clemmitt Sigler
				Va. Tech Physics Dept.

Comment 1 csigler 1999-08-11 14:37:59 UTC
Oops, my bad -- I should have said both these machines were stock
RH 6.0 *upgrades* from RH 5.2.  Sorry.  CMS

Comment 2 Bill Nottingham 1999-08-16 20:28:59 UTC
works fine here with cyrillic fonts, without, etc.

Do you have a demonstration page that it crashes on?

Comment 3 csigler 1999-08-17 14:15:59 UTC
Hi,

These are the example pages:

http://www.al.com/

Clicking on the Java links to the left worked last week after removing
the cyrillic fonts .rpm and also worked on my DEC Alpha running DU
4.0F with Netscape 4.5. Now neither one works, which makes me think
the Java on these sports pages has been updated and now is not
Netscape- or Java-compliant.

Symptom: Clicking on any of the Java links to the left may or may not
cause Netscape to go into a coma when loading the requested page.
Seems to be inconsistent.

System: RH6.0 upgrade from standard RH5.2 installation.  Netscape
version 4.51. Font path thing fixed, of course. Same behavior seen on
a similar system running RH 6.0/Netscape 4.61 after font path fix.

Wish I could be of more help.  If you can't reproduce this behavior
please close this bug report.  I'll just chalk it up to faulty
configuration (having no idea how to fix that :^P).

					Clemmitt Sigler
					Virginia Tech

Comment 4 Bill Nottingham 1999-08-17 16:53:59 UTC
Hm. Using netscape-4.61, I can't get anything strange to happen
on that page. For now, I'm closing this as 'works for me'.