Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4468

Summary: x server crashes due to font path problem
Product: [Retired] Red Hat Raw Hide Reporter: prabirm
Component: XconfiguratorAssignee: Matt Wilson <msw>
Status: CLOSED NOTABUG QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 1.0CC: prabirm
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-08-24 01:09:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description prabirm 1999-08-11 02:15:09 UTC
The XConfigurator configures the font path entries in the
file "/etc/X11/XF86Config" as

   FontPath   "unix/:-1"

because of this the x-server always crashes and you can
never start X11 using "startx" or directly after boot up.

I changed the parameters to the followings:

#   FontPath   "unix/:-1"
    FontPath    "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath    "/usr/X11R6/lib/X11/fonts/Type1/"
    FontPath    "/usr/X11R6/lib/X11/fonts/Speedo/"
    FontPath    "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath    "/usr/X11R6/lib/X11/fonts/100dpi/"

And "xdm" or "kdm" is working perfectly now.

BTW, the rawhide release date is "4th August, 1999"
I have a ViewSonic P655 with ATI Rage Pro II video card

Regards,
Prabir

Comment 1 Bill Nottingham 1999-08-11 14:04:59 UTC
Did you actually have the font server running?

Comment 2 Cristian Gafton 1999-08-24 01:09:59 UTC
Probably the font server was not running, because it works for me.