Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4466

Summary: mgetty-1.1.14-policy.patch, poor system configuration due to root email patch.
Product: [Retired] Red Hat Linux Reporter: niggemyer
Component: mgettyAssignee: David Lawrence <dkl>
Status: CLOSED WONTFIX QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-08-31 20:23:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description niggemyer 1999-08-10 19:26:55 UTC
The mgetty-1.1.14-policy.patch which changes the default
MAIL_TO from "faxadmin" to "root" is unnecessary, and takes
away from flexibility of the overall system.

Most people probably do not want an e-mail sent to root
every time a fax comes in.  In a large installation, this
could become very burdensome.  Rather than put the
responsibility on the mail client to filter all these
messages out, why not just send all fax mail to "faxadmin"?
(as mgetty was smartly designed to do so in the first
place).

Redhat has already gone to the trouble of making
an /etc/aliases file with entries for system, admin,
postmaster, etc.  Since this mechanism is alredy in place,
the simple addition of another line in /etc/alaises, ala

faxadmin: root

would make a working fax system much more usable.  The
admin could very easily send the fax mails to root, another
user, /dev/null, or a number of any other things.

Compiling in MAIL_TO=root makes sending the mail anywhere
other than to root very hard!!  It seems silly to need to
use procmail or other filtering mechanisms if you don't
want root to get hundreds of e-mails about mgetty recieving
faxes.

K. Brant Niggemyer

Comment 1 Jeff Johnson 1999-08-31 20:23:59 UTC
The file /etc/aliases, in the sendmail package, is marked
%config(noreplace). What that means is, if I add faxadmin as
an alias and compile MAILTO=faxadmin into mgetty, is that mail
to faxadmin will break on upgrades. I'm going to punt and leave
MAILTO=root because at least the mail gets through even though
that requires root to use a filter. You can, of course, apply
the patch to mgetty and recompile. Red Hat can't do this because
of the way sendmail is packaged.