Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4462

Summary: initlog hangs when running programs with much output
Product: [Retired] Red Hat Linux Reporter: Leo Bergolth <leo>
Component: initscriptsAssignee: Bill Nottingham <notting>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 6.0CC: leo, rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-08-10 18:35:51 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Leo Bergolth 1999-08-10 16:37:05 UTC
When I call
action "Checking filesystem quotas" /sbin/quotacheck -va
in rc.sysinit, after the filesystems have been mounted,
quotacheck hangs after some disk activity forever.

Running quotacheck -va directly, without action works.

It looks like the syslog call of initlog blocks.
(quotacheck -v displays a rotating bar which causes very
much output.)

Comment 1 Bill Nottingham 1999-08-10 16:43:59 UTC
Aack, first fsck, now quotacheck.

OK, try the following:
1) upgrade to the latest initscripts in Raw Hide.
2) add an 'ignore' regexp to /etc/initlog.conf that
catches quotacheck's progress bar.

Does this help?

Comment 2 Bill Nottingham 1999-08-10 18:35:59 UTC
this will be fixed in initscripts-4.29-1, which will be in the
next Raw Hide release.