Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4412

Summary: rpm-3.0.3-0.9 will not build due to a missing netdb.h test in ./configure
Product: [Retired] Red Hat Raw Hide Reporter: Joseph Malicki <malicki.1>
Component: rpmAssignee: Jeff Johnson <jbj>
Status: CLOSED NOTABUG QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 1.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-08-08 16:28:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Joseph Malicki 1999-08-07 04:00:01 UTC
I have had numerous problems building rpm-3.0.3-0.9
since ./configure does not check for netdb.h, leaving
HAVE_NETDB_H undefined in config.h, so system.h will not
#include <netdb.h>.  The simple fix was to change #undef
HAVE_NETDB_H in config.h.in to #define HAVE_NETDB_H 1, but
having configure actually test for it would be nice.

Also, perhaps the code should be written so configure would
fail if struct hostent is not found in any header files,
which is what the build failure is due to.

Comment 1 Jeff Johnson 1999-08-08 16:28:59 UTC
From rpm/configure.in:
...
AC_CHECK_HEADERS(fcntl.h getopt.h grp.h memory.h netdb.h pwd.h
utime.h)
...