Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4380

Summary: openssl missing
Product: [Retired] Red Hat Secure Web Server Reporter: fdragon
Component: securewebAssignee: Preston Brown <pbrown>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 2.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-08-29 16:34:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description fdragon 1999-08-05 19:38:45 UTC
OpenSSL is installed as a single binary in /usr/sbin as
/usr/sbin/openssl, but none of the support routines for
OpenSSL are installed. Not sure if installing OpenSSL
locally afterwards will fix this so that I can use the perl
Net:SSLeay module without breaking the secureweb-3.0 RPM.

Comment 1 Preston Brown 1999-08-29 16:34:59 UTC
when you say, "support routines," what are you referring to?  If you
are referring to headers, etc. needed to compile your own SSL-enabled
programs, then this is intentional; we are only allowed to include the
RSA encryption in the product we distribute, and have no license to
allow 3rd parties to use the RSA encryption routines in their own
programs/products.