Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4365

Summary: old readline segfaults new gdb
Product: [Retired] Red Hat Linux Reporter: psyclone42
Component: readlineAssignee: David Lawrence <dkl>
Status: CLOSED WORKSFORME QA Contact:
Severity: medium Docs Contact:
Priority: low    
Version: 5.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-08-05 13:33:30 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description psyclone42 1999-08-05 08:25:31 UTC
i noticed that readline-2.2-4 makes gdb-4.17.0.11-6 dump
core -- only debug info i could get was that the actual
segfault was in _IO_fflush (iofflush.c:41). there may be
other things it crashes.. suggest a minimum version for
readline be added, as readline-2.2.1-5 fixes it. (sure is
nice to have gdb back :) )

Comment 1 Jeff Johnson 1999-08-05 13:33:59 UTC
This is a glibc shared library problem. You cannot mix glibc-2.0.x
shared libraries with glibc-2.1 shared libraries because of structure
changes in libio (e.g. _IO_fflush). Recompile the old readline.

Comment 2 openshift-github-bot 2015-09-08 23:54:05 UTC
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/081f34cf30c79584a15c4c0aa8101181fa077e76
Issue 4365 - example github url as a link is really confusing