Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4327

Summary: Why pump is not operated in RedHat6.0?
Product: [Retired] Red Hat Linux Reporter: nukejun
Component: pumpAssignee: Erik Troan <ewt>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: mads
Target Milestone: ---   
Target Release: ---   
Hardware: alpha   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-15 21:40:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description nukejun 1999-08-03 05:12:10 UTC
Hi, my name is Jun working for Samsung Advanced Institute of Technology.
I am using the kernel 2.2.5 including bootp request option on
Alpha 533Mhz 21164a, 164LX system.
As the kernel proceeds in booting, it receives the IP address
and hostname automatically from one server.
However, one error occurrs in "ifup" script program.
In "ifup", "pump -i eth0" is called.
Error message is "Operation failed"
so, networking is impossible.
I have experimented executing "pump" in RedHat 5.2.
There was not any problem.
Only in RedHat 6.0, "pump" was not operated.
------------------
   In RedHat6.0
  glibc-2.1.1-7
  pump-0.7.0-1
------------------
   In Redhat5.2
  glibc-2.0.7-29
  pump-0.7.0-1
------------------
I can guess the reason...maybe glibc problem...

Possible faults
1. glibc bug
2. pump bug
3. my mistake in kernel compiling with bootp option.
4. my mistake in network configuration files...(very low possibily)

Please, help me....~_~

Comment 1 Jay Turner 1999-08-03 15:10:59 UTC
We are aware of problems with pump on the alpha architecture and are
working to release an update which will resolve these problems.  In
the mean time, you can always make use of dhcpcd from the 6.0 package,
as it should work as before.

Comment 2 Mads Kiilerich 1999-08-13 10:50:59 UTC
I experienced similar problems after having upgraded a celeron to
kernel 2.2.11.

Perhaps I didn't include the right options, idunno...

Regards, Kiilerich

Comment 3 Erik Troan 2000-02-15 21:40:59 UTC
If these problems have persisted, please reopen this bug.