Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4289

Summary: glibc has Problems with long lines in /etc/group
Product: [Retired] Red Hat Linux Reporter: Wissmann, Klaus <kw>
Component: glibcAssignee: Jakub Jelinek <jakub>
Status: CLOSED WORKSFORME QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: aleksey, fweimer, holger
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-04-21 23:33:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Wissmann, Klaus 1999-07-31 20:20:34 UTC
We have an /etc/group file with several very long lines (the
longest is 1747 chars). I built a qmail rpm which has files
in it that belong to the groups "nofiles" or "qmail". When I
have those two groups in our /etc/group file *before* the
long lines there is no problem. When I put those groups in
/etc/group *after* the long lines rpm prints

  group qmail does not exist - using root

when installing this rpm. I am using rpm-3.0.2-5.x both to
build and install the rpm.

Comment 1 Jeff Johnson 1999-12-16 16:14:59 UTC
This isn't an rpm problem per se, since rpm does not access /etc/group
directly, but only uses getgrnam/getgrgid interfaces from glibc. (Note:
there is a hard coded maximum 1024 group limit in rpm, but I don't believe that
you are reaching that limit). Off to glibc for resolution ...

Comment 2 Alan Cox 2002-12-15 04:23:09 UTC
Still present in 8.0


Comment 3 Ulrich Drepper 2003-04-21 23:33:50 UTC
I cannot reproduce this with RHL9.  I have at the beginning of /etc/group a line
with >2000 characters.  My user entry is behind this and rpmbuild happily
creates an output file even though the files which get added belong to me.

Please check this out yourself and report back.