Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4266

Summary: too many BOOTP or DHCP domain-name-servers cause installer to SEGF
Product: [Retired] Red Hat Linux Reporter: chris
Component: installerAssignee: Matt Wilson <msw>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: jeld, wenger
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-11 15:12:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description chris 1999-07-30 09:39:58 UTC
The following dhcpd.conf configuration will cause the
redhat-6.0 installer (also under 5.2 and 5.1, none others
tested) to segfault just after the DHCP or BOOTP request.

subnet 192.168.1.0 netmask 255.255.255.0 {
        option routers 192.168.1.1;
        option domain-name-servers 192.168.1.1, 192.168.1.2,
203.2.192.124, 203.2.193.124;
#       option domain-name-servers 192.168.1.1;
        option domain-name "melb.interline.aust.com";
        range dynamic-bootp 192.168.1.193 192.168.1.250;
}

It will work fine if the domain-name-servers is wound back
to a single entry (as per the commented field). Only 4 or 1
entries tested.

Recommended fix is to not segfault (duh!), but just ignore
any execess entries. (ie, if your initial nameservers are
broken, you should be fixing the problem rather than
installing a new redhat box ;)

Comment 1 Jay Turner 1999-08-02 15:26:59 UTC
*** Bug 4274 has been marked as a duplicate of this bug. ***

I have tried to install RH 6.0 on a Pentium II system using
bootnet.img. System has a 3com 3c900 card. I am running a
FreeBSD DHCP ( ISC ) server. When it gets to requesting DHCP
for an IP address I get
"install exited abnormally -- recieved signal 11"
message. On other consoles it indicates that address was
succesfully obtained from DHCP. DHCP serves IP address,
default router, DNS servers, WINS server and NetBIOS node
type 0x8. If you need more information write me.

------- Additional Comments From jeld@mindless.com  07/30/99 12:52 -------
Sorry. It looks that I have encountered the same problem as is
described in bug #4266. I have changed DHCP config and the problem
went away. This is still a bug though :) now I have to change the
dhcp.conf back and restart it just because I tried to install an RH
station :)

Comment 2 Jay Turner 2000-02-11 15:12:59 UTC
Fixed in the latest version of the installer.