Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4261

Summary: apmd resume failure
Product: [Retired] Red Hat Linux Reporter: kgb
Component: apmdAssignee: Bernhard Rosenkraenzer <bero>
Status: CLOSED RAWHIDE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-12-09 10:54:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description kgb 1999-07-30 00:17:31 UTC
After installing Errata to Rehat 6.0 apmd-3.0beta5-8
experienced resume failures - i.e. if the system was
left suspended for a long time the system would freeze
on resume and had to be power cycled. Eeek!

Switching back to apmd-3.0beta5-7 from the CD seems
to have fixed the problem.

Comment 1 kgb 1999-07-30 00:18:59 UTC
PS system was a Gateway 9100 XL notebook

Comment 2 kgb 1999-08-11 20:10:59 UTC
More information:

The problem is NOT fixed by changing back the apmd.

Here is a better description of the problem:

If one suspends/resumes then at first there appears to be now
problem. However if one stays in the virtual console (e.g. F1)
for 1-2 minutes eventually something odd happens that locks out the
keyboard completely. If one switches back to X11 before this happens
the problem never manifests.

One can recover if one is able to telnet into the machine from
elsewhere. Simply saying 'chvt 7' in the telnet window works.

So what can happen after a resume to lock out the keyboad?

Comment 3 kgb 1999-09-02 23:58:59 UTC
Some more information:

I captured /proc/* and process listing by logging in from a networked
terminal when I experienced this problem today. I then recovered OK
by doing 'chvt 7' as root. Obviously this fix only works if one is
connected to the network!

See

ftp://ftp.aao.gov.au/pub/local/kgb/bug4621/

for my process snapshow.

Comment 4 Bernhard Rosenkraenzer 1999-11-11 15:46:59 UTC
Try the apmd package from Raw Hide (3.0beta9-4), enabling the CHVT
stuff.

Comment 5 Bernhard Rosenkraenzer 1999-12-09 10:54:59 UTC
As I didn't get any new feedback, I'm assuming the new package fixed it.

Comment 6 kgb 1999-12-09 11:42:59 UTC
Sorry, just got round to testing it.

Couldn't find 3.0beta9-4 but found and tried 3.0beta9-6.

This does indeed fix the problem.

thanks!

Karl