Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4172

Summary: incorrect csh syntax in /etc/profile.d/kde.csh
Product: [Retired] Red Hat Linux Reporter: shikari67
Component: kdesupportAssignee: David Lawrence <dkl>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
URL: http://www.crystalcave.net/~edh
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-07-23 09:00:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description shikari67 1999-07-23 01:11:38 UTC
The /etc/profile.d/kde.csh init script has a bug.  It
appears to be sing sh(1) syntax to assign a variable, but
csh(1) requires the "set" keyword.  A diff follows, with
some logic/cosmetic tweaks.  Hope this helps!  --Eric

*** kde.csh.FCS Mon Jun 21 13:28:21 1999
--- kde.csh     Thu Jul 22 19:53:32 1999
***************
*** 1,13 ****
  # KDE initialization script (csh)
  if ( $?KDEDIR ) then
!          if ( $KDEDIR == "/usr" ) then
!          exit
!          endif
  endif
  setenv KDEDIR /usr
! kdepath="${KDEDIR}/bin"
! if ( echo ${PATH} | grep -q ${kdepath} ) then
!   exit
  endif
-
- setenv PATH "${kdepath}:${PATH}"
--- 1,12 ----
  # KDE initialization script (csh)
  if ( $?KDEDIR ) then
!     if ( $KDEDIR == "/usr" ) then
!         exit
!     endif
  endif
  setenv KDEDIR /usr
! set kdepath="${KDEDIR}/bin"
! echo ${PATH} | grep -q "${kdepath}:"
! if ( $status ) then
!     setenv PATH "${kdepath}:${PATH}"
  endif

Comment 1 Jeff Johnson 1999-07-23 09:00:59 UTC
*** This bug has been marked as a duplicate of 3686 ***