Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4104

Summary: User Account Privileges Bug
Product: [Retired] Red Hat Linux Reporter: Brian Z <brian>
Component: linuxconfAssignee: David Lawrence <dkl>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-07-30 21:30:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Brian Z 1999-07-18 17:00:52 UTC
When creating/modifying a user in linuxconf and specifying
the privilege to use linuxconf, the user will get a
Permision Denied error when typing linuxconf in the shell.

Comment 1 Jay Turner 1999-07-20 17:55:59 UTC
Verified in test lab.  Created new user and gave them permission to
use linuxconf.  When logged in as user, get permission denied message
when executing linuxconf command.

Comment 2 Michael K. Johnson 1999-07-30 21:30:59 UTC
This is by design.  To turn on this feature, make linuxconf setuid
root and executable by users that you want to be able to run it.
We do not ship linuxconf setuid root because we do not trust it
setuid root from a security standpoint.  This is an optional feature
and making linuxconf setuid root is the only way to enable it, by
design.