Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4044

Summary: ppp with pap login does not create utmp entry
Product: [Retired] Red Hat Linux Reporter: rh
Component: pppAssignee: David Lawrence <dkl>
Status: CLOSED WORKSFORME QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-08-30 02:42:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description rh 1999-07-15 00:01:22 UTC
Using mgetty with AutoPPP to login with PAP. The user shows
up on wtmp (last etc shows), but does not show up on utmp
(w, who or finger doesn't show the user).

Comment 1 igmar 1999-07-22 10:42:59 UTC
This is becuase the user is not an actual system user. The entry is
only in /etc/ppp/pap-secrets, and NOT in /etc/passwd. A user is only a
user if it is in /etc/passwd

This is one of the consequences of using AutoPPP

Comment 2 Cristian Gafton 1999-08-30 02:42:59 UTC
The sue that should show up is the a_ppp user.