Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3775

Summary: broken kde.csh login script
Product: [Retired] Red Hat Linux Reporter: adler
Component: kdesupportAssignee: David Lawrence <dkl>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: adler
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-06-29 15:45:51 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description adler 1999-06-28 12:39:47 UTC
The file

/etc/profile.d/kde.csh

is broken as of kdesupport-1.1.1-1. The kde.csh file
has bad csh syntax and bombs when you try to execute
it becase of the bad syntax.

Here is a diff file where I fixed the csh syntax

[root@phyppro2 profile.d]# diff kde.csh kde.csh.orig
8,9c8,9
< set kdepath="${KDEDIR}/bin"
< if ( `echo ${PATH} | grep -q ${kdepath}` ) then
---
> kdepath="${KDEDIR}/bin"
> if ( echo ${PATH} | grep -q ${kdepath} ) then
14d13
<

Comment 1 Derek Tattersall 1999-06-29 15:45:59 UTC
*** This bug has been marked as a duplicate of 3686 ***