Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3769

Summary: "pump" *appending* to /etc/resolv.conf instead of *replacing* it.
Product: [Retired] Red Hat Linux Reporter: Bill Bradford <mrbill>
Component: pumpAssignee: Erik Troan <ewt>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: pjones
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-03 16:49:15 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Bill Bradford 1999-06-28 05:20:13 UTC
I just took a look at my /etc/resolv.conf file:

[root@cs2867-221 /root]# cat /etc/resolv.conf |wc -l
   2990

I'm a Time Warner (Austin) RoadRunner cable modem
subscriber, and my machine is configured via DHCP/pump when
it boots.

Apparently every time I've rebooted or up/downed my ethernet
interface, pump has been just appending the DNS server info
to /etc/resolv.conf instead of *appending* to it.  I'm
running the updated version of pump from the errata (I've
already filed one other, more serious bug on it . . )

Here's a (very) small sample of the file:

[root@cs2867-221 /etc]# head -50 resolv.conf
search austin.rr.com rr.com
nameserver 24.93.35.65
nameserver 24.93.35.64
nameserver 24.93.35.33
nameserver 25.93.35.32
nameserver 101.116.104.48
nameserver 0.5.0.0
nameserver 180.1.0.0
nameserver 118.0.0.0
nameserver 113.4.0.0
nameserver 96.84.0.0
nameserver 0.6.0.0
nameserver 51.0.0.0
nameserver 79.4.0.0
nameserver 185.5.0.0
nameserver 78.3.0.0
nameserver 84.1.0.0
nameserver 43.5.0.0
nameserver 79.1.0.0
nameserver 67.6.0.0
nameserver 65.1.0.0
nameserver 122.6.0.0
nameserver 74.3.0.0
nameserver 52.3.0.0
nameserver 167.5.0.0
nameserver 72.6.0.0
nameserver 172.6.0.0
nameserver 194.1.0.0
nameserver 160.4.0.0
nameserver 68.5.0.0
nameserver 138.3.0.0
nameserver 120.5.0.0
nameserver 144.6.0.0
nameserver 21.2.0.0
nameserver 245.4.0.0
nameserver 79.5.0.0
nameserver 134.2.0.0
nameserver 160.1.0.0
nameserver 169.5.0.0
nameserver 147.3.0.0
nameserver 85.3.0.0
nameserver 98.2.0.0
nameserver 153.2.0.0
nameserver 85.5.0.0
nameserver 77.6.0.0
nameserver 179.2.0.0
nameserver 23.5.0.0
nameserver 104.5.0.0
nameserver 254.1.0.0
nameserver 208.5.0.0

Everything works, I just noticed my resolv.conf was a TAD
bigger than it should have been. 8-)

Thanks.

Bill

Comment 1 Anonymous 1999-06-28 05:25:59 UTC
er, that should have read "just appending the DNS server info to
/etc/resolv.conf instead of *replacing* it".  My typo.

Comment 2 Jay Turner 1999-06-28 12:33:59 UTC
This issue has been forwarded to a developer for further action.

Comment 3 Michael K. Johnson 1999-09-25 19:48:59 UTC
I think that this bug was fixed in pump-0.7.2, available from
RawHide; at least, I can no longer reproduce it in my setup.
If you could test it in yours (truncate your resolv.conf file
before testing, obviously... :-) we would certainly appreciate
it.  RawHide packages are available from
ftp://ftp.redhat.com/rawhide/

Comment 4 Erik Troan 2000-02-03 16:49:59 UTC
Fixed in pump on the errata