Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3720

Summary: rpm --checksig dumps core (rpm-3.0-6.0.i386.rpm)
Product: [Retired] Red Hat Linux Reporter: Sam Varshavchik <mrsam>
Component: rpmAssignee: Jay Turner <jturner>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 6.0CC: alborchers, srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
URL: http://www.geocities.com/SiliconValley/Peaks/5799/rpm-coredump.tar.gz
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-06-25 10:15:34 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Sam Varshavchik 1999-06-24 23:40:15 UTC
PGP 2.6.2 is installed, logged in as root, but root does not
have $HOME/.pgp subdirectory.

"rpm --checksig --nopgp" works.

"rpm --checksig" dumps core.

Core dump is available at
http://www.geocities.com/SiliconValley/Peaks/5799/rpm-coredump.tar.gz

Comment 1 Jeff Johnson 1999-06-25 10:11:59 UTC
*** Bug 3523 has been marked as a duplicate of this bug. ***

"rpm --checksig" core dumps with a segmentation fault when
run by a non-root user with pgp 2.6.3 or 2.6.2.  When run by
root, or when run by a normal user but with "--nopgp", there
is no problem.  An strace ends like this

...
fcntl(3, F_GETFL)                       = 0 (flags O_RDONLY)
fstat(3, {st_mode=S_ISUID|S_ISVTX|0406, st_size=0, ...}) = 0
mmap(0, 4096, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40001000
_llseek(0x3, 0, 0, 0xbfff7a50, 0x1)     = -1 ESPIPE (Illegal
seek)
read(3, "\n\7Keyring file \'/home/borcher"..., 4096) = 274
read(3, "", 4096)                       = 0
close(3)                                = 0
munmap(0x40001000, 4096)                = 0
wait4(1027, [WIFEXITED(s) && WEXITSTATUS(s) == 1], 0, NULL)
= 1027
unlink("/var/tmp/rpmsihPzRUu")          = 0
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++

-- Al Borchers
   alborchers@steinerpoint.com

------- Additional Comments From jbj@redhat.com  06/17/99 11:06 -------
What does "rpm -q rpm" report?

------- Email Received From  Al Borchers <alborchers@steinerpoint.com> 06/17/99 15:45 -------


------- Additional Comments From jbj@redhat.com  06/17/99 16:23 -------
Do you have pgp5 installed?

Are your ~/.rpmmacros and/or PGP_* env variables different?

Could you also try rpm-3.0.1-12.6.0 from ftp.rpm.org? A couple
of signature (as well as other) problems are fixed there.

------- Additional Comments From alborchers@steinerpoint.com  06/19/99 23:50 -------
Ah, yes, the .rpmmacro files are different on the two machines.  On
the machine where it does NOT core dump, there is NO .rpmmacro file.
On the machine where it DOES core dump, there is an .rpmmacro file
with this line

%_pgp_path /home/borchers/.pgp/pubring.pgp

This probably came from an earlier 5.2 installation.  When I removed
this file, I could do "rpm --checksig" as a non-root user.

Thanks,
-- Al

>"rpm -q rpm" reports rpm-3.0-6.0.
>
>Another comment: I tried "rpm --checksig ..." on another machine, as
a
>non-root user, also with RH 6.0 and it DID NOT core dump.  Doubled
>checked
>on my first machine, and it DID core dump.  The machines are
>different
>hardware, but very similar RH 6.0 installations.  Both have pgp
>2.6.3.

Comment 2 Jeff Johnson 1999-06-25 10:15:59 UTC
Fixed in rpm-3.0.2-0.9. Thanks a lot for the report, particularly
for pointing out how to reproduce (missing $HOME/.pgp).