Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 372

Summary: Missing "lastlog" rotation in /etc/logrotate.conf
Product: [Retired] Red Hat Linux Reporter: scottbeverly
Component: logrotateAssignee: Cristian Gafton <gafton>
Status: CLOSED NOTABUG QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1998-12-10 23:58:42 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description scottbeverly 1998-12-09 20:36:29 UTC
Maybe this isn't a bug, but I'm posting it anyway because if
it was left out on purpose then the comment should be
changed.

In /etc/logrotate.conf I found the following:

# no packages own lastlog or wtmp -- we'll rotate them here
/var/log/wtmp {
    monthly
    rotate 1
}

######## yet although the comment mentions lastlog there was
not an entry for it in the config file.  Here is what I
believe should have followed the above entry (or something
similar):

/var/log/lastlog {
    monthly
    rotate 1
}

Comment 1 Cristian Gafton 1998-12-10 23:58:59 UTC
lastlog should not be rotated, as it will not grow in size (it stores
the timestamps of the last login for each UID, and the max number of
UIDs is 65535, so ,ax size it will be 64K users * 6 bytes each record.

Comment 2 scottbeverly 1998-12-11 00:18:59 UTC
Yup, that makes total sense to me.  So it was incorrect to have it
rotated in previous versions, and the comment in the file should be
changed to remove mention of rotating lastlog, no?

Comment 3 Jeff Johnson 1998-12-31 20:51:59 UTC
*** Bug 372 has been marked as a duplicate of this bug. ***

logrotate.conf doesn't handle lastlog, even tough it's
supposed to, and does not compress logs by default
[version 2.6-3]

------- Additional Comments From dkl@redhat.com  12/23/98 10:56 -------
This report reduces to a policy question, (why doesn't logrotate
rotate lastlog) and a product improvement suggestion, (why doesn't
logrotate compress back level logs).

------- Additional Comments From borgia@students.cs.unibo.it  12/26/98 18:02 -------
No, it is not a policy question! Please read the comments in your own
products:

From /etc/logrotate.conf as shipped in 5.2:
-cut-cut-
# no packages own lastlog or wtmp -- we'll rotate them here
/var/log/wtmp {
    monthly
    rotate 1
}

# system-specific logs may be configured here

Doh: the script says it should handle lastlog, but doesn't...


------- Additional Comments From ayn2@cornell.edu  12/26/98 18:38 -------
This bug report is a duplicate of #372

Comment 4 borgia 1999-01-06 08:17:59 UTC
Ok, sorry, lastlog should not be rotated but then the comment in
logrotate.conf is a bit misleading... "bug" closed, I'd say.