Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3678

Summary: Losing all X input (mouse/keyboard)
Product: [Retired] Red Hat Linux Reporter: Brandon Black <brandon.black>
Component: XFree86Assignee: Preston Brown <pbrown>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: brandon.black, klotz, wilson
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-09-01 14:32:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Brandon Black 1999-06-23 17:52:43 UTC
At random times, but generally when while I'm moving the
mouse cursor around a lot and generally while a have
terminal windows open (but neither case applies always), I
will lose the ability to give X any further input via the
mouse.  The mouse cursor still moves about on the screen,
but fails to have any effect on any windows, window
manager... etc... it doesn't even change mouse icons as it
should over various regions.  When this happens, keyboard
input gets suspended as well....

Crtl-Alt-F1 still works to bring me back to text mode, and
Alt-F7 still brings me back into X, but my input will still
not be working in X (works fine in text mode though).
Ctrl-Alt-Backspace also still works, and after the server
restarts the problem is gone.

I'm not running gpm at all in text mode, I don't use the
mouse in the text consoles.

I'm running Gnome and E! under X, with fairly not-too-fancy
settings, and cpu load was never high at the time of the
input hang (my cpu load is almost never high).

The machine is an IBM Thinkpad 770Z (Celeron 366, 256MB Ram,
etc....).  The mouse is the internal "eraser-button" mouse
on all Thinkpads, and it acts as a PS/2.

No similar loss of mouse or keyboard input occurs when
booted to Win98.

Please let me know if you ned more any other info, or come
up with some debugging instructions that might help out...

Comment 1 Preston Brown 1999-07-15 20:53:59 UTC
If you can verify that this problem occurs with other window managers,
such as KDE or WindowMaker?  That would help eliminate E as the source
of the problem, which is what I expect might be the problem.

Comment 2 wilson 1999-08-30 03:33:59 UTC
I too am seeing this same problem.  I have seen the problem under
multiple window managers.  Most recently under the AfterStep.  I am
using the I128 accelarated server.  At first I thought it was a 24-bit
problem, but it happened again in 8-bit mode.  I thought I had
upgraded to 3.3.3.1 but xdpyinfo reports 3330.  rpm -q -a | grep X
reports 3.3.3.1-52.  CPU is a 200 MHz P-pro w/ 64 MB and Imagin 128 -
8MB card

Comment 3 Preston Brown 1999-09-01 14:32:59 UTC
XFree86 3.3.5 (a forthcoming errata release) has several PS/2 mouse
fixes.  If your problems fail to disappear after you have upgraded to
that errata release, please re-open the bug.