Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3647

Summary: rxvt core dumps
Product: [Retired] Red Hat Linux Reporter: Steve Wills <steve>
Component: rxvtAssignee: Preston Brown <pbrown>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-08-20 15:07:34 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Steve Wills 1999-06-22 20:50:13 UTC
Run:

rxvt -sl 32767 -fg white -bg black -fn fixed

then, run "find /" on a drive with a large number of files
and rxvt will core dump with this message:

rxvt: screen.c:889: scr_add_lines: Assertion `screen.cur.row
>= -TermWin.nscrolled' failed.
Aborted (core dumped)

Comment 1 Derek Tattersall 1999-06-29 15:06:59 UTC
Fails on 6.0 also.

Comment 2 Bill Nottingham 1999-08-20 15:07:59 UTC
Seems to be fixed in the latest rxvt in 6.1.