Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3641

Summary: kickstart fails if partitions are not specified
Product: [Retired] Red Hat Linux Reporter: Joshua Buysse <buysse>
Component: installerAssignee: Matt Wilson <msw>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-09-19 23:06:00 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Joshua Buysse 1999-06-22 18:31:51 UTC
I'm attempting to use kickstart to partially automate the
install process -- having the system ask about network and X
configuration, since the machines I need to install are not
especially similar.  I'm mainly using kickstart to provide a
way to automate package specification and a post-install
customization.

The problem that I'm running into is that the installer does
not ask about partitioning if none is specified in the
kickstart file.  I've got a wide variety of machines.

Another minor annoyance (I would just customize the
kickstart file for each machine with a script otherwise) is
that the 'part' keyword does not allow you to specify a disk
to place the partition on.  On the machines that have
multiple disks, I want control over the swap partitions,
etc.

Comment 1 Joshua Buysse 1999-06-23 20:28:59 UTC
A good solution in my mind for a future version of the installer would
be a '--ask' option for any of the kickstart keywords, so you could
specifically state 'network --ask' or 'part --ask'.

Comment 2 Jay Turner 2000-02-10 21:03:59 UTC
Added to a list of feature requests for future releases.

Comment 3 Michael Fulbright 2000-09-19 23:05:57 UTC
Should be fixed in the Pinstripe beta release.