Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3626

Summary: Misleading comments in sample bash_profile and bashrc
Product: [Retired] Red Hat Linux Reporter: Telsa Gwynne <hobbit>
Component: bashAssignee: Cristian Gafton <gafton>
Status: CLOSED NOTABUG QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-07-28 06:26:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Telsa Gwynne 1999-06-21 23:01:50 UTC
The /etc files for bash profile and bashrc have comments at the top which suggest that all environment variables should go in the bash_profile, not the bashrc. If you find a variable that needs setting (I had to set COLORFGBG for something) and put it in .bash_profile, it won't get picked up by any new bash you spawn unless you specifically say it should be a login shell or tell it to source the profile. This means that any gnome-terminals or xterminals you start don't pick it up. Presumably the answer is to put the variable into the profile, yes, but the comments on the profile say they should go in the rc. Trivial, yes, but trivial to fix, at least :)

Comment 1 Telsa Gwynne 1999-06-21 23:25:59 UTC
I'm a twit and sending you rubbish. Switch profile and rc in the penultimate sentence starting "presumably the answer..", and colour me embarrassed. I intended to say that as variables you want to be picked up should go in bashrc not profile, the comments in the two sample files implying variables live in profile should be updated. Apologies. I did proof-read before sending; I just didn't do it very well. Now I just hope this gets added to bug 3626 and not made into a new one.

Comment 2 Jay Turner 1999-06-22 14:34:59 UTC
This issue has been forwarded to a developer for further review.

Comment 3 Cristian Gafton 1999-07-28 06:26:59 UTC
The comments are correct as far as I can tell. The treatment of the
dot files in user home directories is different (and somewhat
documented in the bach info pages)