Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3615

Summary: Page colors and properties dialog box crashes Netscape 4.6.1
Product: [Retired] Red Hat Linux Reporter: neutecnico
Component: netscapeAssignee: David Lawrence <dkl>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-06-21 14:21:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description neutecnico 1999-06-21 14:00:24 UTC
When using Netscape Communicator i open a Composer window
and try to change page properties, if i change something
(for example, the packground color or the document title)
and then press the OK button to close the dialog box,
Netscape crashes and closes all its windows.

The workaround for this is to modify page settings, then
press the APPLY button and then close the dialog by
clicking on the window's manager "X" (close window) button.

I'using Gnome and the Enlightenment window manager, and i
installed all the latest upgrades for XFree86, the kernel,
plus the utempter update and other stuff, my machine is a
Pentium II 233 with 128Mbyte of ram.

I know the XFree86 update was supposed to fix some problems
with applications using the statically linked Motif toolkit
(like Netscape does, as far i know), but event this does not
resolve the problem.
I think the problem is in the "OK" button click code, or in
the way the Motif toolkit communicates with XFree86
(by clicking on the window manager provided "x" button
 i actually bypass part of the Motif toolkit code).

Lorenzo Micheletto
neutecnico@iol.it

Comment 1 Jay Turner 1999-06-21 14:21:59 UTC
Unable to replicate this in test lab on any machines.  Reopen this bug
if you are able to pin this problem down any further for us.