Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3577

Summary: kswapd may die after a suspend
Product: [Retired] Red Hat Linux Reporter: adavid
Component: kernelAssignee: Bernhard Rosenkraenzer <bero>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
URL: http://www.docs.uu.se/~adavid/linuxbug.html
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-03 16:09:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description adavid 1999-06-18 17:49:12 UTC
Just suspend a portable running apmd-3.0beta5-8 under linux
kernel version from 2.2.6 to 2.2.10 (maybe earlier) and if
you are lucky, your kswapd may die after a while, which is
random but very probable and you may see nice dumps on the
screen like those on this page (see web page).
I know that kswapd dies because ps tells me that kswapd is a
zombi. The result of this is: a process is just blocked. If
you are lucky it could be gcc that you are
using, but if you are not, it could be X or mingetty, that
has happened to me many times, and I did not know why. Now I
suspect kswapd to be guilty.

I give several kernel dump errors retrieved from my logs and
a typical boot sequence of my machine.

regards

Alexandre

Comment 1 Michael K. Johnson 1999-07-13 18:20:59 UTC
We do not ship kernel versions 2.2.6 through 2.2.10; we ship a
patched version of 2.2.5.  Does this problem exist on our
kernel 2.2.5-22 package?

Comment 2 adavid 1999-07-14 14:12:59 UTC
The bug is present in linux 2.2.5-22 shipped by redhat as well.
I got a crash yesterday and I have updated my web page to
include another trace:
www.docs.uu.se/~adavid/linuxbug.html

Comment 3 Zach Brown 1999-07-14 15:10:59 UTC
Is there any chance you can pin this down to a version of
apmd being at fault rather than the act of going through the
bios?  the APM calls walk through the bios, which we don't have source
for.  if suspend reliably doesn't work on your machine you may be
forced to ask your BIOS vendor for patches.

if nothing else, can you feed your oopsen through ksymoops so we
have full symbol lookups and disassemblies for the kernels you were
running?

Comment 4 adavid 2000-02-03 16:03:59 UTC
The problem seems solved for kelnels >= 2.2.13
coupled with an updated BIOS.