Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3572

Summary: SGML-tools doesn't work on its own example file
Product: [Retired] Red Hat Linux Reporter: Eric Raymond <esr>
Component: sgml-toolsAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: ed, ewt
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-07-13 18:28:00 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Eric Raymond 1999-06-18 14:42:17 UTC
Script started on Fri Jun 18 01:28:46 1999
snark:~/WWW/writings/magic-cauldron$ sgml2latex --output=ps
--papersize=letter+example.sgml
Processing file example.sgml
This is TeX, Version 3.14159 (Web2C 7.3)
LaTeX2e <1998/12/01
Babel <v3.6k> and hyphenation patterns for american, french,
german, ngerman,
+n
ohyphenation, loaded.

! example.tex

! LaTeX Error: File `article.cls' not found.

Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: cls)

Enter file name:
! Emergency stop.
<read *>

l.2 \usepackage
               {linuxdoc-sgml}^^M
No pages of output.
Transcript written on example.log.
dvips: ! DVI file can't be opened.
snark:~/WWW/writings/magic-cauldron$ exit

Script done on Fri Jun 18 01:29:06 1999

Comment 1 Michael K. Johnson 1999-07-13 18:28:59 UTC
This is (I presume) caused by an rpm bug that affected tetex, and is
fixed by the rpm packages at
http://www.redhat.com/corp/support/errata/rh60-errata-general.html#rpm

You can fix it even without reinstalling rpm by reinstalling the
tetex packages, but we strongly suggest upgrading rpm at the same
time.