Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3562

Summary: Wrong pseudo tty modes
Product: [Retired] Red Hat Linux Reporter: David Balažic <david.balazic>
Component: screenAssignee: David Lawrence <dkl>
Status: CLOSED ERRATA QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-06-18 15:18:47 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description David Balažic 1999-06-18 09:04:22 UTC
screen-3.7.6-6 set the pseudo tty perms and owner/group incorrectly.
By default it sets it to mode 622 user : user , group : user
that is for user stein it is set to :
crw--w--w-   1 stein    stein    136,   5 Jun 18 10:59 5
But logging in via ssh and telnet set it to :
crw--w----   1 stein    tty    136,   4 Jun 18 10:59 4

Comment 1 David Balažic 1999-06-18 10:49:59 UTC
I noticed in the original screen 3.7.6 sources that it sets the
group of PTY to PTYGROUP, if symbol PTYGROUP is defined.
I executed configure and it DID set PTYGROUP to 5, which is correct.
I compiled it and it works sorta good. Set tty ownership correctly,
but uses ttya0 and not pts/1 :-)

Comment 2 David Balažic 1999-06-18 14:45:59 UTC
Seem to be fixed after installing screen-3.7.6-9 and dev-2.7.7-2.

Comment 3 Bill Nottingham 1999-06-18 15:18:59 UTC
yup, this was part of the errata fix.