Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3529

Summary: mzip could't handle SCSI zip drives
Product: [Retired] Red Hat Linux Reporter: Péter, Soós <sp>
Component: mtoolsAssignee: Cristian Gafton <gafton>
Status: CLOSED WORKSFORME QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-09 16:40:05 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Péter, Soós 1999-06-17 14:29:52 UTC
I have an internal SCSI zip drive, but mzip can't handle it.
The setting in my mtools.conf looks like:
drive z: file="/dev/sdc" partition=4 scsi=1 nodelay

The mzip -r z: command results a similar error message:
mzip: open(stat): No such file or directory

Comment 1 Alan Cox 1999-06-18 14:40:59 UTC
Using scsi=1 expects the relevant scsi generic device. Using
scsi=0 file=/dev/sdc4 should be fine

Comment 2 Péter, Soós 1999-06-28 12:09:59 UTC
The solution above not helps. The error message is:
mzip: stat(none) failed: No such file or directory

Comment 3 Cristian Gafton 2000-02-09 16:40:59 UTC
It works here in the lab if you give it the right partition number...