Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 352

Summary: Failure when /tmp not on same filesytem as /etc
Product: [Retired] Red Hat Linux Reporter: ncb
Component: sndconfigAssignee: David Lawrence <dkl>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1998-12-08 19:46:15 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description ncb 1998-12-08 18:46:56 UTC
WriteConfModules() in sndconfig.c uses rename() to move a
temporary conf.modules into place.  This fails when the
temporary file is not on the same filesystem as /etc.  (I
have a patch.)

Comment 1 Bill Nottingham 1998-12-08 19:46:59 UTC
*** This bug has been marked as a duplicate of 196 ***