Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3514

Summary: netscape won't run on sun4c
Product: [Retired] Red Hat Linux Reporter: mackbw
Component: netscapeAssignee: Bill Nottingham <notting>
Status: CLOSED DEFERRED QA Contact:
Severity: medium Docs Contact:
Priority: high    
Version: 6.0CC: davem, mackbw, rvokal, scohen
Target Milestone: ---   
Target Release: ---   
Hardware: sparc   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-08-24 16:38:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description mackbw 1999-06-16 22:39:07 UTC
I have installed the netscape rpm's that come with red hat linux 6.0...
When I try to run it from a shell I get the following...
          "Warning: translation table syntex error: Modifier or ' ' expected
            Warning: ... found while parsing 'Alt '
            Illegal Opperation"

    This is what occurs most of the time... Sometimes I just get the
Illegal Opperation message, sometimes I get nothing. Netscape did
come up once. and ran for a while, then crashed... I have tried reinstalling
or installing just the navigator package rather than the communicator
package with the same results...

   I am running a Sun SparcStation 2. A Hayes
 Compat External Modem... I do have access to the internet with it...
I just can't get Netscape running.

Comment 1 Bill Nottingham 1999-06-23 22:11:59 UTC
What keymap are you running with?

Comment 2 Bill Nottingham 1999-07-16 16:41:59 UTC
Netscape seems to have serious problems on sun4c machines - this
could explain the problems you're seeing.

Comment 3 Bill Nottingham 1999-07-28 22:55:59 UTC
*** Bug 4076 has been marked as a duplicate of this bug. ***

Netscape will abort a launch attempt if it has been
previously closed with Edit Preference Java Script
selected.  It crashes (without a core dump) with 'Illegal
Instruction' message.

If the .netscape directory is deleted from your home
directory, Netscape will launch correctly.  Exit (or close)
Netscape - you'll not be able to launch again until
the .netscape directory is deleted.

However, if after it launches the Edit Preferences Java
Script option is de-selected, Netscape can then be closed
and launched correctly.

Once launched, if the Edit Preferences Java Script is re-
selected, Netscape will crash when the Edit Preferences
window is closed.

This process is repeatable on my SunSPARCstation IPX with
64Mb memory, Weitek chip, and Sun 8 bit frame buffer color
monitor.

------- Additional Comments From scohen@acxiom.com  07/16/99 11:52 -------
FYI.  Three commands were entered prior to running the events
described in this report.  They were:

chkfontpath --add /usr/X11R6/lib/X11/fonts/75dpi
chkfontpath --remove /usr/X11R6/lib/X11/fonts/100dpi
/etc/rc.d/init.d/xfs restart



------- Additional Comments From scohen@acxiom.com  07/16/99 11:54 -------
Several components were upgraded prior to running the events
described in this report.  They include

kernel to 2.2.5-22
XFree stuff upgraded from -49 to -52 as found on rh errata pages.

------- Additional Comments From notting@redhat.com  07/16/99 12:37 -------
Unable to replicate on Ultra5 or Sparc10.
Able to replicate (somewhat; it never actually starts)
on an IPX. (with 14M memory. This took a while to test. ;) )

I'd say that sparc netscape has sun4c problems. :(

I'll report it to netscape, although since they seem to
have forgotten to release a 4.6 or 4.61 for sparc, I'm
not sure how concerned they are about fixing it.



------- Additional Comments From scohen@acxiom.com  07/16/99 12:46 -------
Make certain you're launching netscape-communicator.  netscape-
navigator 'just sits there' as you say.  Remember to launch
communicator after having deleted the .netscape directory.

------- Additional Comments From notting@redhat.com  07/16/99 13:07 -------
Nope -
netscape-communicator SIGILLs immediately, regardless of the
state of the ~/.netscape directory.
netscape-navigator sits spinning after its dns-helper process
SIGILLs.

------- Additional Comments From scohen@acxiom.com  07/16/99 14:35 -------
Some success was seen in launching with the following options:

netscape-communicator -noinstall -ncols 128

You might also try -ncols 4 or some very low number.

Also, I often had to re-boot the computer.  This forced the system to
launch netscape from disk rather than from system memory cache.

Another tip - try restarting xfs.

------- Additional Comments From notting@redhat.com  07/16/99 23:39 -------
Nope, seems to be pretty much broken on all the sun4c's we have here.
DaveM, any particular reason it would blow up on sun4c and not 4m/4u?

Comment 4 Bill Nottingham 1999-08-24 16:38:59 UTC
Reported to netscape; awaiting a fix from them.