Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3497

Summary: lower part of display looks distorted
Product: [Retired] Red Hat Linux Reporter: Thomas Moschny <moschny>
Component: kernelAssignee: Cristian Gafton <gafton>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-06-29 18:55:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Thomas Moschny 1999-06-16 11:31:57 UTC
hardware: ultra1 (ultrasparc)
software: rh 6.0: kernel-2.2.5-22, XFree86-Sun-3.3.3.1-49
display: 1152x900x8
symptom: the bottom say 20-30 lines of the display look
distorted, because everything is drawn with a shift to the
left, but this shift is different for different types of
graphics (pixmaps, fonts, etc).
notes: I'm really not sure if this is related to X or to the
framebuffer. AFAIR the problem appeared with kernel 2.2.5.
It was not there while we used Ultrapenguin 1.1.9.
The problem is also not observed with rh 6.0 (same rpms as
above) on a sparcstation4.

Comment 1 Jay Turner 1999-06-29 18:55:59 UTC
Try out the XFree86-3.3.3.1-52 packages and see if they remedy the
problem.  Reopen the bug if you are still having problems.

Comment 2 Thomas Moschny 1999-06-30 09:19:59 UTC
The problem remains the same with the XFree86-3.3.3.1-52 packages.

Comment 3 Jay Turner 1999-06-30 14:00:59 UTC
What framebuffer device is in this machine??  Also, what X-server are
you running on this ultra?

Comment 4 Thomas Moschny 1999-06-30 15:28:59 UTC
/proc/fb reports: "0 CGsix"; this is an sbus framebuffer.
The X-Server is the one from XFree86-Sun-3.3.3.1-52.
Kernel ist still kernel-2.2.5-22 for sparc64.
http://www.theorie.physik.uni-wuppertal.de/~moschny/screenshot.jpg
(~162k) shows a screenshot to illustrate my problem.

Comment 5 Thomas Moschny 1999-06-30 16:10:59 UTC
In bug #2446 my problem is already reported by someone else (as an
problem which occurs in a system with two CG6-framebuffers).
Hope this helps.

Comment 6 Thomas Moschny 1999-08-26 12:23:59 UTC
Since kernel 2.2.11 the problem is no longer observed.