Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3494

Summary: No fsck leaves system fscked
Product: [Retired] Red Hat Linux Reporter: spurius
Component: installerAssignee: Matt Wilson <msw>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-10 20:05:22 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description spurius 1999-06-16 05:04:51 UTC
Due to my previous 2 bugs with the installer, which occured
many times until I made temporary solutions to them, I never
thought to manually fsck the root partition, trusting in the
installer.  However, the installer mounted un-fscked drives
even if they reported as being bad.  This happening several
times in a row... well, let me just give you one of my many
boot errors.

/etc/rc.d/rc.sysinit is a gimp plugin and must be run by the
gimp in order to be used.

As you can see, my system was horribly mangled.  I'm still
working on recovering as much as I can.  I never even
thought to manually fsck after each error.

Please fix these 3 bugs I've reported.  They have caused me
great pain and downtime.

Comment 1 Jay Turner 2000-02-10 20:05:59 UTC
fsck has been added to rescue mode for the latest release which will allow you
to boot up in rescue mode, fsck the disk and then reboot into the installer.