Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3481

Summary: SMB client zero file lengths
Product: [Retired] Red Hat Linux Reporter: Stephen John Smoogen <smooge>
Component: sambaAssignee: Trond Eivind Glomsrxd <teg>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: joed
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-07-21 14:38:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Stephen John Smoogen 1999-06-15 16:21:41 UTC
Joe Doran <joed@pc-ltd.co.uk> writes:

I have come across a bug which has shown its head in
smbclient on redhat 6.0.

I have installed the basic redhat 6.0 product and whilst
doing a mget from an NT server I  have noted some files
retreived have a zero byte content. I have replicated this
with the contributed version 2.04b from your website.
However if you get the individual files one by one, voila it
works.

I have also tried other versions of 2.03 and 2.04 running
under netbsd and they perform correctly, so it appears to be
a redhat problem only.

Maybe it is a filesystem problem within redhat?

Comment 1 Bill Nottingham 1999-06-15 21:06:59 UTC
are you using the stock kernel? If so, have you tried one
with CONFIG_SMB_WIN95 turned off?

Comment 2 Bill Nottingham 1999-07-21 14:38:59 UTC
closed due to lack of input.