Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3473

Summary: PUMP core dumps when DNS hosts are sent without a DOMAIN
Product: [Retired] Red Hat Linux Reporter: breed
Component: pumpAssignee: Erik Troan <ewt>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-06-22 19:30:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description breed 1999-06-15 08:25:35 UTC
If dns server option is returned without a domain option,
pump will core dump, since it doesn't check for a null
domain in createResolveConf().

I would suggest skipping over existing search records in
resolv.conf if the domain isn't present to at least preserve
what is there.

Comment 1 breed 1999-06-15 16:11:59 UTC
There is a patch that fixes this and other problems in pump (as well
as reporting errors in syslog) at
http://www.cse.ucsc.edu/~breed/pump.patch.

Comment 2 Erik Troan 1999-06-22 19:30:59 UTC
This was fixed a while ago, and the version on the errata should
already include the fix.