Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3440

Summary: pump does not produce the same information that dhcpcd (which it replaces) used to produce.
Product: [Retired] Red Hat Linux Reporter: dittrich
Component: pumpAssignee: Erik Troan <ewt>
Status: CLOSED WONTFIX QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-03 15:47:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description dittrich 1999-06-13 22:54:32 UTC
I've been using, with RH 5.2, ipchains rules and scripts as
written by Robert Zeigler:

        http://rlz.ne.mediaone.net/linux/faq/index3.html

Unfortunately, under 6.0, the dhcpcd interface information
file is no longer created, so ipchains rules use the
IP address I had months ago when I was still at 5.2 and thus
don't work.

The directory /etc/dhcpc exists and is writable:

[root@stimpy network-scripts]# ls -ld /etc/dhcpc
drwxrwxr-x   2 root     root         1024 Jun  6 17:41
/etc/dhcpc

This is not the problem.  It is not the same issue
as bug #3097, and bug #3132 (which I can't seem to reopen
as it is marked a duplicate) does not address the
matter (and asking me to code back in the use of dhcpcd
is *not* an adequate solution if I intend to produce
default ipchains rules to be used by others on the UW
campus.  If the solution involves that level of
hacking, it isn't general enough.

If pump is to replace dhcpcd, it should provide the same
mechanisms for ease of integration with scripts that need
the resulting addresses, etc. (as dhcpcd provided).
Please have the engineer(s) who wrote pump address this.

Thanks very much.
--
Dave Dittrich
dittrich@cac.washington.edu

Comment 1 Jeff Johnson 1999-06-14 15:35:59 UTC
The issues regarding pump are being addressed (read: pump is
primitive) but there is no solution as of today (or probably for the
next month).

Meanwhile, dhcpcd is distributed with Red Hat 6.0 and there is
an update that includes the directory in which the file needed by
ipchains exists. I'd think seriously abou using dhcpcd if you
need a solution today and are unable and/or unwilling to help
fix pump.

Comment 2 Erik Troan 1999-06-22 18:54:59 UTC
Is using 'pump -s' from your scripts not a good enough way of getting
the status information you need? I intended that to include everything
your type of application might need.

Please let me know what else pump -s should include.

------- Email Received From  Dave Dittrich <dittrich@cac.washington.edu> 06/24/99 10:29 -------


------- Email Received From  Erik Troan <ewt@redhat.com> 06/24/99 11:04 -------


------- Email Received From  Dave Dittrich <dittrich@cac.washington.edu> 06/24/99 14:48 -------

Comment 3 Erik Troan 2000-02-03 15:47:59 UTC
If pump -s does not address your needs, please let me know. It should contain
the proper information, and we believe it is a reasonable alternative to
/etc/dhcpc