Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3418

Summary: dip doesen't work on 386 processor
Product: [Retired] Red Hat Linux Reporter: x
Component: dipAssignee: David Lawrence <dkl>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-06-14 17:02:54 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description x 1999-06-12 16:57:12 UTC
After uprgrading an old 386 system to RH 6.0 dip
appears to work correctly but the modem hangs up after
establishing the connection (dip terminates).

After rebuilding the SRPM on a stock RH 6.0 system dip works
again. My guess is that it has been compiled with some
optimizations turned on (586 and higher).
See also bug 3413(bind) (which was the same here) and
ipchains.

Comment 1 Alan Cox 1999-06-13 00:36:59 UTC
Another bswap case. Might be worth us running objdump scns across
everything to be sure we get the lot

Alan

Comment 2 Bill Nottingham 1999-06-14 17:02:59 UTC
*** This bug has been marked as a duplicate of 3413 ***