Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3335

Summary: System clock is reset incorrectly on boot
Product: [Retired] Red Hat Linux Reporter: rodsmith
Component: initscriptsAssignee: David Lawrence <dkl>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-06-23 19:58:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description rodsmith 1999-06-08 14:37:02 UTC
After upgrading from Red Hat 5.2 to 6.0, I find that Red Hat
sets my hardware clock forward every time I reboot.  The
amount increases with increasing amounts of time shut off
(the clock increments close to an hour after being off
overnight), so I suspect that the init scripts' calls to
/sbin/hwclock are to blame (or, more likely, the default
values in /etc/adjtime -- doing rpm -V initscripts reveals
that this file hasn't been changed on my system since it was
installed).

Comment 1 David Lawrence 1999-06-11 22:24:59 UTC
There were some time problems found when using apmd on laptops and
some desktops where the time was set to GMT inappropriately. Please
update to the errata rpm pf apmd at ftp://updates.redhat.com/6.0/i386
and reopen this bug if that doesnt solve your problem.

Comment 2 rodsmith 1999-06-14 00:29:59 UTC
Upgrading the APMD RPM (I'm now using apmd-3.0beta5-8) does *NOT*
solve the problem.  I'm using a FIC PA-2011 motherboard in a desktop
system, and the system clock is set to local time, not GMT.  Time
shifts are not usually in even multiples of an hour.

Comment 3 Bill Nottingham 1999-06-17 21:29:59 UTC
what happens if you comment out the:

$CLOCK --adjust

line in rc.sysinit?

------- Email Received From  "Roderick W. Smith" <rodsmith@channel1.com> 06/17/99 18:11 -------

Comment 4 Bill Nottingham 1999-06-23 19:58:59 UTC
The adjust of the hardware clock is removed as of
initscripts-4.22, available in the next Raw Hide release....