Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3330

Summary: gdm doesn't chown /dev/console
Product: [Retired] Red Hat Linux Reporter: Marc MERLIN <marc_soft>
Component: gdmAssignee: Michael K. Johnson <johnsonm>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-07-30 19:59:49 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Marc MERLIN 1999-06-08 05:01:58 UTC
Because of this, I can't write in my xconsole.
I tried to setup gdm just like xdm and take advantage of:
PreSessionScriptDir=/etc/X11/gdm/PreSession
PostSessionScriptDir=/etc/X11/gdm/PostSession

to chown /dev/console as appropriate, just like xdm does,
but that doesn't work either and ls -lu, shows that gdm
does not even open those files :-(

Comment 1 Marc MERLIN 1999-07-13 05:46:59 UTC
I was just checking on the status of this bug, and realized that I
messed up the summary, but bugzilla doesn't give me any way to change
it.
Anyway, what I meant to write there was "gdm doesn't chown
/dev/console"

Comment 2 Michael K. Johnson 1999-07-13 14:55:59 UTC
I changed the summary for you.  :-)

You do appear to be correct that a gdm login ought to give
you ownership of /dev/console; I'm looking to see if any
other instances of this exist and whether to use pam_console
as a general solution.

Comment 3 Michael K. Johnson 1999-07-30 19:59:59 UTC
This will be fixed for gdm, and unified between gdm, xdm, and kdm,
in the next release, as it will be done entirely through the
pam_console module.  Thanks!