Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3234

Summary: dnsquery, route, unable to resolve anything
Product: [Retired] Red Hat Linux Reporter: tom
Component: bindAssignee: Cristian Gafton <gafton>
Status: CLOSED WORKSFORME QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-08-19 21:57:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description tom 1999-06-03 10:16:10 UTC
dnsquery is unable to look up addresses without help, eg:

[tom@skybowl tom]$ dnsquery telstra.net
Query failed (h_errno = 2) : Host name lookup failure

If I specify a nameserver it's able to use DNS (it's even
the same DNS server that's listed in /etc/resolv.conf).

[tom@skybowl tom]$ dnsquery -n 203.56.242.1 telstra.net
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 26208
;; flags: qr rd ra; QUERY: 1, ANSWER: 6, AUTHORITY: 3,
ADDITIONAL: 4
;;	telstra.net, type = ANY, class = IN
telstra.net.		48m41s IN NS	ns.telstra.net.
telstra.net.		48m41s IN NS	svc01.apnic.net.
telstra.net.		48m41s IN NS	ns1.telstra.net.
telstra.net.		48m38s IN A	139.130.204.2
telstra.net.		48m38s IN MX	10 postoffice.telstra.net.
telstra.net.		48m38s IN MX	5 mailhost.telstra.net.
telstra.net.		48m41s IN NS	ns.telstra.net.
telstra.net.		48m41s IN NS	svc01.apnic.net.
telstra.net.		48m41s IN NS	ns1.telstra.net.
ns.telstra.net.		1d13h25m49s IN A  203.50.0.137
svc01.apnic.net.	5h37m12s IN A	202.12.28.131
ns1.telstra.net.	48m11s IN A	139.130.4.5
postoffice.telstra.net.  48m38s IN A  139.130.4.7

A utility such as host still works fine without help:
[tom@skybowl tom]$ host telstra.net
telstra.net has address 139.130.204.2
telstra.net mail is handled (pri=10) by
postoffice.telstra.net
telstra.net mail is handled (pri=5) by mailhost.telstra.net

As a side effect I also note that 'route' isnt able to
resolve hosts:

[tom@skybowl tom]$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric
Ref    Use Iface
203.56.242.2    *               255.255.255.255 UH    0
0        0 eth0
203.56.242.0    *               255.255.255.0   U     0
0        0 eth0
127.0.0.0       *               255.0.0.0       U     0
0        0 lo
default         stronghold.tm.n 0.0.0.0         UG    0
0        0 eth0

Comment 1 Jeff Johnson 1999-06-06 16:20:59 UTC
I'm changing the component to bind because that's the package that
contains dnsquery.

Route resolves hostnames quite well, even in your example. Perhaps
your DNS needs some attention ...

Comment 2 tom 1999-06-06 16:38:59 UTC
erg (don't submit bugs late at night I think is the moral) in regards
my route embarrassment. However, dnsquery is definitely buggy.

The RedHat 5.2 machines are able to use dnsquery, but not the 6.0
ones.

Comment 3 Jay Turner 1999-06-29 11:29:59 UTC
Confirmed the dnsquery problem in the test lab.

Comment 4 Jay Turner 1999-06-29 11:30:59 UTC
Confirmed the dnsquery problem in the test lab.

Comment 5 Bill Nottingham 1999-08-19 21:57:59 UTC
works OK with the latest dnsquery from bind in Raw Hide.