Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3189

Summary: readmsg seg faults (elm-2.5.0-0.2pre8)
Product: [Retired] Red Hat Linux Reporter: jprosa
Component: elmAssignee: Jay Turner <jturner>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.0CC: srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-06-05 15:59:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description jprosa 1999-06-01 04:55:02 UTC
executing: /usr/bin/readmsg \*
causes a seg fault

It segs in: readmsg.c at line 341

if(get_mssg_info(&minfo, fstate.sel_list[i] != 0)

The problem seems to be with fstate.sel_list being an
(int *) and w/ bad bounds checking.

See ya.

Comment 1 Jeff Johnson 1999-06-04 17:43:59 UTC
I've just packaged elm2.5.0-1 (the official release). If you
get a chance, could you see if seg-fault persists there.

Send mail to <jbj@redhat.com> and I'll send you the rpms.

Thanks.

Comment 2 Jeff Johnson 1999-06-05 15:59:59 UTC
Fixed in elm-2.5.0-2. Thanks for the analysis and patch!