Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3184

Summary: anonftp problem with DIR
Product: [Retired] Red Hat Linux Reporter: Veillard, Daniel <daniel.veillard>
Component: anonftpAssignee: David Lawrence <dkl>
Status: CLOSED WORKSFORME QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-06-01 20:51:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Veillard, Daniel 1999-05-31 22:20:41 UTC
23:15:02 <DV_> BTW: the ~ftp/bin/ls in RH-6.0 seems to be a
ZMagic not supported by the RH-6.0 kernel anymore ...
23:15:15 <_Anarchy_> DV: rotfl
23:15:25 <_Anarchy_> DV: bugs@

  So did I ...

anonftp package is broken on RH-6.0 the ls binary is a
ZMAGIC one which doesn't load on the standard RH-6.0 kernel,

Daniel

Comment 1 David Lawrence 1999-06-01 20:51:59 UTC
The standard kernel that is shipped with redhat 6.0 has a.out format
enabled as a module according to /usr/src/linux/arch/i386/defconfig. I
was unable to get the ls executable to fail by running it directly
from /home/ftp/bin and also connecting through anonymous login. Is it
possible you have a.out support disabled in a custom kernel you may be
using?