Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 315

Summary: Inability to load second stage on NFS install
Product: [Retired] Red Hat Linux Reporter: darkwing
Component: installerAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1998-12-07 21:28:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description darkwing 1998-12-06 04:50:50 UTC
I'm trying to do an NFS install. The ethernet card
(EtherExpress) is autodetected and name lookup works. When
I give the program a (valid) name and directory of an
installation archive, the following is output to a console:

* calling mount(sipb-nfs:/redhat/5.2/i386, /tmp/rhimage,
nfs, -105820971, 0x80b4504)
* method selection completed
* writing network information to /tmp/ifcfg-eth0
* state saved to /tmp
* error in exec of second stage loader :-(
*       error:No such file or directory

I've tried this on multiple servers, and verified on each
that the path is accessible, mountable, and contains the
proper files with the proper permissions.&#137;

Comment 1 David Lawrence 1998-12-06 20:41:59 UTC
Have you been able to get any previous installs to work from this tree
on different workstations?

Comment 2 darkwing 1998-12-06 21:10:59 UTC
A different machine produces the same error on two install trees on
two distinct NFS servers.
Interestingly, though, the install program can mount a 5.1 install
tree and proceed into second stage install, though with the (expected)
error "/usr/lib/rpmrc: No such file or directory"&#137;

Comment 3 darkwing 1998-12-06 22:20:59 UTC
A different machine produces the same error on two install trees on
two distinct NFS servers.
Interestingly, though, the install program can mount a 5.1 install
tree and proceed into second stage install, though with the (expected)
error "/usr/lib/rpmrc: No such file or directory"&#137;

Comment 4 David Lawrence 1998-12-07 21:28:59 UTC
The 5.1 and 5.2 boot disks are not interchangeable due to a different
location of /var/lib/rpmrc. As for the other problem I have not been
able to replicate the problem in the lab. I would do a permissions
comparison between the working 5.1 tree and the 5.2 tree to make sure
all files and directories are set correctly.