Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3098

Summary: Telnet's escape character can't be disabled.
Product: [Retired] Red Hat Linux Reporter: Antti Andreimann <antti.andreimann>
Component: telnetAssignee: Jay Turner <jturner>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
URL: ftp://ftp.sisalik.ee/pub/telnetfix
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-06-02 13:47:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Antti Andreimann 1999-05-27 17:46:18 UTC
telnet -e "" or telnet -E still respond to ^@ as escape
character. The problem is that ascii code of ^@ is equal
to zero and the value of _POSIX_VDISABLE used in telnet
source code is also set to zero by header files.
The problem can be fixed by throwing <A
HREF=ftp://ftp.sisalik.ee/pub/telnetfix/telnet-0.10-escapechar.patch>this</A>
patch into
telnet's source code (after the telnet-client.tar.gz file
has been uncompressed).
Netkit's default telnet (that is not used) does exactly the
same tests as this patch.
The fixed telnet source rpm as well as spec file, patch and
i386 binary rpm are available at:
       ftp://ftp.sisalik.ee/pub/telnetfix
I am sorry if this is a bad way to submit a bug fix.
I did not want to upload this package to contrib or rhcn.
If someone can contact me and explain how to do it in a
right way I'd appriciate it.

Comment 1 Antti Andreimann 1999-06-02 13:12:59 UTC
I did e-mail my patch to bugzilla and it's visible from query page. I
really have to start reading help screens and FAQ-s :-) I hope you can
include my patch in next official release.

Comment 2 Jeff Johnson 1999-06-02 13:47:59 UTC
Fixed (by applying your patch) in telnet-0.10-28. Thanks for the
patch.