Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 3016

Summary: tasks spawned by at fail if they rely on wait
Product: [Retired] Red Hat Linux Reporter: jlarmour
Component: atAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-05-24 21:11:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description jlarmour 1999-05-24 20:33:47 UTC
at sets the signal handler of SIGCHLD to SIG_IGN, resulting
in the child inheriting this. This causes any grandchildren
to quit immediately rather than becoming zombies that
can be "wait"ed for by the child. A similar problem to this
(problem #732) was fixed for cron.

I will send a patch along via e-mail, since I don't appear
to have access to upload RPMs any more (more work for
you!).


------- Email Received From  Jonathan Larmour <jlarmour@cygnus.co.uk> 05/24/99 16:37 -------

Comment 1 Jeff Johnson 1999-05-24 21:11:59 UTC
Patch applied in at-3.1.7-9. Thanks for reporting.