Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 2973

Summary: NFS3 mounts no longer possible after upgrade to RedHat 6.0
Product: [Retired] Red Hat Linux Reporter: Hermann Schichl <hermann.schichl>
Component: knfsdAssignee: David Lawrence <dkl>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 6.0CC: bill, derek.bamford, m.davis2, rshapiro
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-06-17 17:43:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Hermann Schichl 1999-05-22 22:39:16 UTC
After upgrading to RedHat 6.0 NFS version 3 mounts
are not longer possible.

Result: Kernel message: svc: unknown version (3)

Server: Out of the box RedHat 6.0 system
Client: Digital Alpha running Digital UNIX 4.0

Comment 1 Jeff Johnson 1999-05-23 05:29:59 UTC
NFS3 mounts have never been supported under linux. However, the
return code returned from knfsd when NFS3 mounts are attempted
confuses the client into not trying NFS2.

A work around is to explicitly request NFS version 2 when mounting
on the client. I dunno what the DU 4.0 syntax is. If you succeed
in doing the mount, could you add the syntax you used to this bug
report? Thanks

Comment 2 Hermann Schichl 1999-05-23 10:33:59 UTC
Explicitly requesting Version 2 mounts from
Digital UNIX is done using the 'nfsv2' mount
flag as in:

  mount -o nfsv2 serverhost:serverdir clientdir

-----------------------------------------------

After browsing through the source of kernel nfsd I figured
out that NFS 3 mounts should be possible in principle. However,
CONFIG_NFSD_NFS3 is not defined, which would (as it seems)
include NFS 3 support.
The interesting stuff is in nfs3proc.c, nfs3xdr.c, and nfssvc.c
all in fs/nfsd.

Comment 3 Jeff Johnson 1999-05-23 16:13:59 UTC
AFAIK, NFS3 is not yet functional. Thanks for the DU 4.0 syntax
and analysis.

Comment 4 Jeff Johnson 1999-05-25 15:23:59 UTC
*** Bug 3019 has been marked as a duplicate of this bug. ***

There is a problem in the interaction between the Kernel
nfsd and the rpc.mountd command. The kernel provides
services for NFS version 2, but rpc.mountd registers itself
as supporting version 1,2 and 3. This causes an NFS3 client
(like SGI IRIX) to try to mount a linux filesystem using
version 3, but whenever it tries to do any actual I/O on the
filesystem, the I/O fails with a version error.

I worked around the bug by fixing the NFS startup script to
pass -V 2 -N 3 as arguments to rpc.mountd.

A better fix would of course be to add support for NFS V3.
It looks like there are bits and pieces of it in the kernel
sources, but they did not seem to make it into the build.

Comment 5 Jeff Johnson 1999-06-03 14:02:59 UTC
I just packaged knfsd-1.3.3-1 -- still no man pages or NFSv3.

Comment 6 Jeff Johnson 1999-06-17 17:43:59 UTC
Man pages are now in knfsd-1.4-1. Still no NFSv3 support, but
the linux mountd will not advertise NFSv3 anymore.