Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 2888

Summary: limited number of characters in password
Product: [Retired] Red Hat Linux Reporter: johnlar
Component: xscreensaverAssignee: David Lawrence <dkl>
Status: CLOSED WORKSFORME QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-05-22 13:06:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description johnlar 1999-05-17 20:07:14 UTC
A password of significant length using the new extented
length passwords will not be accepted in the xscreensaver.
It appears to cut the password off your typing when you are
telling it to use the *'s at about 15 characters. I don't
mind not being able to see the entire password, but even if
I do type the entire thing correctly it will not work and I
have to open another session and kill the screensaver
process which in turn kills the entire X11 server

Comment 1 Derek Tattersall 1999-05-18 20:20:59 UTC
Created a user foo whose password was 20 characters long.  Logged
foo in via gdm.  Locked screen, typed in 20 character password, which
writes off the right end of the box, but unlocked the screen.

Comment 2 johnlar 1999-05-18 23:49:59 UTC
sorry.. didn't give you enough information. the password has to be 21
characters or more (kinda funny that you picked 20 characters) this
seems to be due to the fact that 20 characters is all it will report
when you have the *'s on, but 21 characters won't work without the
stars on anywayssorry.. didn't give you enough information. the password has to be 21
characters or more (kinda funny that you picked 20 characters) this
seems to be due to the fact that 20 characters is all it will report
when you have the *'s on, but 21 characters won't work without the
stars on anyways

Comment 3 johnlar 1999-05-18 23:50:59 UTC
sorry.. didn't give you enough information. the password has to be 21
characters or more (kinda funny that you picked 20 characters) this
seems to be due to the fact that 20 characters is all it will report
when you have the *'s on, but 21 characters won't work without the
stars on anyways

Comment 4 Derek Tattersall 1999-05-19 20:09:59 UTC
I created a user foo with a 25 character password.  gdm had no problem
dealing with it.  xscreensaver didn't have any problem either.
try creating user foo (useradd foo)  set the password to
sqlmeansoctothorpeAUGERin  That's 25 characters, and I can't get it to
fail with xscreensaver-3.09-3 that's installed in 6.0