Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 2848

Summary: Esound doesn't clean up after user logs out
Product: [Retired] Red Hat Linux Reporter: azhao
Component: installerAssignee: Matt Wilson <msw>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: genec
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-09-25 02:46:35 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description azhao 1999-05-16 02:40:31 UTC
Linux supports multiple users, right? Then explain this: the
first user
logs in and enables sound in Gnome and Enlightment,
everything works
fine; when the first user logs out and the second user logs
in, the
second user couldn't use sound support in Enlightment
because "esd"
refuses to run. It turns out that the first user left a
"/tmp/.esd/socket" FIFO file and apparently, "esd" needs to
create that
file for the second user but failed because it already
exists or doesn't
have enough permission to remove it. Removing the socket
file by hand
doesn't solve the problem -- all the audio devices are still
busy for
some reason, even though no "esd" is running at the moment.

I used to complain that the majority of NT programs work for
the user
who installs them but don't work for other non-admin users
(for example
PalmPilot desktop, Office sound support, and many others).
It seems that
"esd" works for the first user but not for anybody there
after.

Comment 1 zurk 1999-06-18 01:43:59 UTC
i have this problem with ksound not cleaning up after itself. everyone
who logs in on the console creates a new ksound process and it simply
stays there.

Comment 2 genec 1999-08-02 04:24:59 UTC
I also have this problem and have a cirvension (for my particular
situation).  I have added a script as /etc/X11/gdm/PostSession/Default
which issues the command /usr/bin/esdctl unlock

This is run as root but seems to work.

Part of the problem is that there is extremely little documentation on
using esound.

Comment 3 Bill Nottingham 1999-09-25 02:46:59 UTC
*** This bug has been marked as a duplicate of 2286 ***