Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 2810

Summary: pgaccess dies on startup
Product: [Retired] Red Hat Linux Reporter: John Morris <jmorris>
Component: postgresqlAssignee: Jay Turner <jturner>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-05-14 14:49:34 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description John Morris 1999-05-14 05:58:38 UTC
Error in startup script: couldn't load file "libpgtcl.so":
/usr/lib/libpgtcl.so: undefined symbol: crypt

The docs for pgaccess mention that things have to be changed
in makefiles.  Here is the relevent section from the docs
for pgaccess:

   PostgreSQL 6.4 release has a minor bug. I does not includ
by default the crypt lib
when compiling libpgtcl. So, you will need to manually add a
-lcrypt to SHLIB line in
Makefile in src/interfaces/libpgtcl and then make clean and
make again. The new
libpgtcl.so library is properly configured to run pgaccess.

Comment 1 Jeff Johnson 1999-05-14 14:49:59 UTC
*** This bug has been marked as a duplicate of 2698 ***